掲示板

※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

動作報告等よろしくお願いします

名前:
コメント:

すべてのコメントを見る

  • 以下のようなエラーが出ます。わかるかた教えていただけませんか?
    ERROR 2018-11-23 11:50:39.807 [main] A serious error occurred during PMS init
    org.jboss.netty.channel.ChannelException: Failed to bind to: /192.168.0.3:5001
    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:303) ~[pms.jar:na]
    at net.pms.network.HTTPServer.start(HTTPServer.java:117) ~[pms.jar:na]
    at net.pms.PMS.init(PMS.java:686) [pms.jar:na]
    at net.pms.PMS.createInstance(PMS.java:1043) [pms.jar:na]
    at net.pms.PMS.main(PMS.java:1116) [pms.jar:na]
    -- (ホリハジメ) 2018-11-23 11:56:17
  • @トンヌラさん
    サーバ側でa-bリピートを実装する方法が思いつきません
    -- (Panasony) 2017-02-06 23:56:35
  • a-bリピート出来るようにして欲しいのですが -- (トンヌラ) 2017-02-04 23:28:56
  • @名無しさん
    >インストール時に使用メモリーのサイズを聞いてくる所のメモリーサイズは
    >インストール後に変更できないのでしょうか?

    レジストリで"PS3 Media Server"を検索して"HeapMem"の値を変更してください

    >2000にするとPmsが起動しないようです。

    コマンドプロンプトで

    java -version

    等で64bit版が実行される事を確認してみてください
    -- (Panasony) 2017-01-03 01:38:24
  • 作者様

    インストール時に使用メモリーのサイズを聞いてくる所のメモリーサイズは
    インストール後に変更できないのでしょうか?
    再インストールでしか設定できない項目でしょうか。

    またこの数値を2000程度にしてはとアドバイスがありましたが、
    2000にするとPmsが起動しないようです。
    980程度にすると起動しますが、それ以上大きな数字では起動できません。

    実装メモリーは8Gです

    -- (名無しさん) 2017-01-02 17:25:43
  • @Panasonyさま

    コマンドベースでの起動、視聴はでき、プラグインも読み込めています。
    TVTestの仕様の方に問題がありそうですね。
    回答ありがとうございました。 -- (名無しさん) 2016-08-31 21:55:07
  • @名無しさん
    TVTestのVer9.0を保有していないので詳細が判りません
    TVTestをコマンドベースで起動し視聴できるか確認してみてください
    例)
    TVTest /d BonDriver_PT3-T.dll /rch 8 /chspace 0 /sid 2080
    -- (Panasony) 2016-08-26 22:59:56
  • こんにちは、PMS for VIERA 1.74.4を使用させていただいています。

    TVTestを9.0にバージョンアップしたところ、テレビ放送のリアルタイム視聴ができなくなりました。

    原因はクライアントから.tvtestファイルでTVTestを起動した際、プラグインが読み込まれず、
    録画ファイルのスクランブル解除がされていないようです。

    TVTest0.7.23では正常にリアルタイム視聴ができますが、設定箇所等ありましたらお教えください。
    -- (名無しさん) 2016-08-22 23:42:25
  • @名無しさん
    Memory: 247 MB と非常に少ない設定になってます。
    インストール時に使用メモリーのサイズを聞いてくる所があるので
    2000程度の値を入力してください
    -- (Panasony) 2016-07-12 00:04:12
  • こんにちわ。以前ISOファイルが数十秒ほどでスキップを繰り返すと質問した物です。
    あれ以降、17.1で利用していたのですが、このほど、最新版を入れてみました。
    しかし同様の状況が起きています。
    下記にデバック情報の必要?部分を掲載します。
    なお、実装メモリーは8Gです。
    DEBUG 2016-07-10 13:17:40.037 [main] My PID is 12728
    INFO 2016-07-10 13:17:41.075 [main] Starting PMS 1.74.5-VIERA
    INFO 2016-07-10 13:17:41.091 [main] Based on PS3 Media Server (ps3mediaserver.org) by shagrath, copyright 2008-2012
    INFO 2016-07-10 13:17:41.097 [main] http://www18.atwiki.jp/pms_viera/
    INFO 2016-07-10 13:17:41.099 [main]
    INFO 2016-07-10 13:17:41.099 [main] Build: 1.5.2-fin (2012-6-14)
    INFO 2016-07-10 13:17:41.100 [main] Java: 1.7.0_60-Oracle Corporation
    INFO 2016-07-10 13:17:41.101 [main] OS: Windows 8.1 64-bit 6.3
    INFO 2016-07-10 13:17:41.102 [main] Encoding: UTF-8
    INFO 2016-07-10 13:17:41.103 [main] Memory: 247 MB
    INFO 2016-07-10 13:17:41.103 [main]
    INFO 2016-07-10 13:17:41.103 [main] Working directory: C:\Program Files (x86)\PS3 Media Server -- (名無しさん) 2016-07-10 13:24:45
  • 遅ればせながら、ffmpegの対応ありがとうございました。
    1.74.5で問題なく動いています。 -- (名無しさん) 2016-06-06 13:54:20
  • @Panasonyさま
    下記の件、やってみましたがダメでした。

    また、念のためMPlayer.exeを最新版に変えてみたのですが変わらずでした。 -- (AAA) 2016-06-01 07:01:20
  • @AAAさん
    rendererがVIERA DIGAである事から問題なさそうです。

    以前の書き込みでインストールディレクトリの
    renderers/DIGA.confにて

    RendererName=PlayStation 3
    RendererIcon=ps3.png
    SeekByTime=true

    と変えるとうまくいったという報告もありました

    -- (Panasony) 2016-06-01 00:27:15
  • 追加です
    ログの気になる所は

    トレースログでは

    INFO 2016-05-31 18:43:59.578 [New I/O server worker #2-13] Starting transcode/remux of 選択したfile.avi
    INFO 2016-05-31 18:44:00.301 [New I/O server worker #2-13] Setting video resolution to: 720x480, your Video Scaler setting
    INFO 2016-05-31 18:44:01.559 [StartPlaying Event] renderer: 192.168.1.31, file: 88F9~1.AVI
    INFO 2016-05-31 18:44:20.563 [StopPlaying Event] renderer: 192.168.1.31, file: 88F9~1.AVI

    またディバックログは

    DEBUG 2016-05-31 18:44:01.599 [Thread-46] Movie-Aspect is 1.82:1 - prescaling to correct movie aspect.
    DEBUG 2016-05-31 18:44:16.560 [New I/O server worker #2-13] Forcing short path name on 選択したfile.avi
    DEBUG 2016-05-31 18:44:19.059 [Buffered IO End Checker] Stopping process: mencoderPS37.exe-7
    DEBUG 2016-05-31 18:44:20.562 [StopPlaying Event] Forcing short path name on 選択したfile.avi
    INFO 2016-05-31 18:44:20.563 [StopPlaying Event] renderer: 192.168.1.31, file: 88F9~1.AVI

    です。
    -- (AAA) 2016-05-31 18:48:43
  • すみません
    入力ミスです

    default Panasonic DIGA

    Panasonic VIERA Panasonic DIGA default

    -- (AAA) 2016-05-31 06:51:55
  • @Panasonyさま

    ステータス画面は
    Connected

    ミドリのレ点

    トランスコードバッファの状態
    Empty
    ビットレート:0Mb/s 最大ビットレート:0Mb/s

    Detected media rendes

    default Panasonic DIGA

    になっております -- (AAA) 2016-05-31 06:14:07
  • @AAAさん
    使用されているrendererはPMSのステータス画面を見れば
    羅列されてます
    -- (Panasony) 2016-05-30 23:37:55
  • @Panasonyさま
    AAAです
    お返事ありがとうございます

    PMSのrenderersに何が選択されてるのでしょうか?
    ーー>すみません どこを見ればわかりますか?
    基本、初期設定のままです。
    多少、表示/共有設定を直しただけです。

    家ではDIGA、VIERAとAmazon fire stick でkdori 以外ありません。

    再起動は数回行いました。 -- (名無しさん) 2016-05-30 06:34:51
  • @AAAさん
    PMSのrenderersに何が選択されてるのでしょうか?
    DIGA、VIERA以外の場合は基本設定のForce default renderer
    を有効にしてdefault rendererをDIGA等に変えて保存して
    再起動してみてください
    -- (Panasony) 2016-05-29 23:35:44
  • @Panasonyさま

    PC上に存在するaviとmp3をPMSを介してデーガにて再生しようとしてるのですか?

    ー>そうです

    デーガではなくテレビのDLNA機能で再生するとどうなるのですか?

    ーー>テレビのDLNA機能でも再生できません。

    今日もDLANサーバでずっとネットで調べて、やっと別のサーバソフトで出来ました。
    Mezzmoというソフトで、ディーガでaviは再生できました。
    (体験版でやってます。3000円くらいなのでこちらで出来なければ購入する予定です)

    PMS for VIERAではできないのでしょうか?
    -- (AAA) 2016-05-29 22:18:17
  • @AAAさん
    PC上に存在するaviとmp3をPMSを介してデーガにて再生しようとしてるのですか?
    その場合がデーガではなくテレビのDLNA機能で再生するとどうなるのですか?
    -- (Panasony) 2016-05-29 19:29:02
  • こんにちは
    家の中、デーガとパナソニックのテレビに揃えてきたので、
    こちらのDLANをiwndows7にインストールしたのですが、
    デーガ同士はからはお部屋ジャンプリングで動画見れるのですが、
    windows7のDLANサーバではファイルは見れるのですが、
    ファイルをデーガからお部屋ジャンプリングで見ようとすると
    「しばらくお待ちください」と出てしまいます。
    aviファイルとmp3fileです。
    写真(jpeg)を見たらちゃんと見れます。

    元のファイルがわるいのでしょうか?
    どなたか優しい方、ヒントだけでもいいので教えていただけると幸いです。 -- (AAA) 2016-05-28 20:11:46
  • ありがとうございました。
    教えて頂いた設定の箇所、いろいろと調整してみます。 -- (BD79) 2016-05-26 07:00:58
  • @BD79さん
    mp4やmkvはトラスコ再生になりますので、サーバ側のPC性能が高くないと
    早送りのレスポンスが悪くなります。また、回線の速度も影響があります。
    変換設定のビデオの品質設定やエンコードサイズ等を調整してみてください。 -- (Panasony) 2016-05-25 23:42:00
  • はじめまして。
    DMP-BD79で使用させていただいておりますが、mp4やmkvで早送りができないという状況だったので、
    BDT330様とPanasony様の以前の書き込みを見て、Rendererの変更等試してみたのですが、
    mp4やmkvの早送りが1段階(おそらく2倍速くらい?)しかできません。
    TSの早送りは全段階可能です。
    なにか思いつく改善策あれば教えていただけないでしょうか?
    -- (BD79) 2016-05-24 16:18:13
  • @名無しさん
    ffmpegをアップデートした事が原因でした。
    修正版をバージョン1.74.5として更新しました。
    -- (Panasony) 2016-05-21 13:24:41
  • mp3ファイルをFFMpegVideoAsAudioで動画偽装しようとすると、
    ffmpegの引数エラーになります。

    DEBUG 2016-05-15 17:24:31.980 [ffmpeg.exe-1] Starting "D:\Program Files\PS3 Media Server\win32\ffmpeg.exe" -sn -sn -sn -sn -i "D:\xxx.mp3" -sn -sn -sn -sn -shortest -loop 1 -t 99999999 -i "D:\Program Files\PS3 Media Server\renderers\images\FFMpegVideoAsAudio.jpg" -vcodec mpeg2video -ab 128000 -vol 128 -f vob -muxpreload 0 pipe:

    DEBUG 2016-05-15 17:24:32.308 [Thread-19] Option shortest (finish encoding within shortest input) cannot be applied to input file D:\Program Files\PS3 Media Server\renderers\images\FFMpegVideoAsAudio.jpg -- you are trying to apply an input option to an output file or vice versa. Move this option before the file it belongs to.
    DEBUG 2016-05-15 17:24:32.308 [Thread-19] Error parsing options for input file D:\Program Files\PS3 Media Server\renderers\images\FFMpegVideoAsAudio.jpg.
    DEBUG 2016-05-15 17:24:32.308 [Thread-19] Error opening input files: Invalid argument

    ※バージョン1.74.4で確認 -- (名無しさん) 2016-05-15 17:43:16
  • @名無しさん
    バージョン1.72.0から64bitに対応した為、メモリ関連の仕様を変更してます。
    ログの頭の方にJavaやOS、Memoryの情報が出力されてると思いますがどうなってますか?
    また、実際にマシンの搭載メモリは幾らですか?
    トラスコバッファのサイズはデフォルトの300(MB)のままですか?
    -- (Panasony) 2016-01-03 02:35:04
  • 続きです。
    PMS for VIERA 1.72.0
    以降をインストールすると、isoスキップする事象が発生します。 -- (名無しさん) 2016-01-02 16:13:17
  • isoは複数試しましたがどれも同じでスキップしました。
    バージョンアップ以前には普通に再生していたisoも最新バージョンでスキップするようになりました。

    以前のバージョンはMS for VIERA 1.71.0だったと思います。
    -- (名無しさん) 2016-01-02 15:02:10
  • encode_m2ts V10を試しました
    問題なくmp4化されているようです
    ありがとうございました -- (名無しさん) 2016-01-01 20:49:09
  • @名無しさん
    そのisoファイル固有の問題の可能性が高いので
    他のisoを色々試してみてください
    -- (Panasony) 2016-01-01 15:57:02
  • @usさん
    sMedio TV Suite を使用できないので
    確認にしようがありません -- (Panasony) 2016-01-01 15:53:28
  • @名無しさん
    iPodEnc.bat を変更しました。
    これで問題が解決すればPMS for VIERAの方に変更を反映します。
    -- (Panasony) 2016-01-01 15:50:44
  • 質問です。
    isoファイルの再生中、突然数十秒の飛び(先送り?)が発生してしまいます。
    10秒ほど再生→数十秒先→10秒ほど再生→数十秒ほど先
    がくりかえしてしまい、ダイジェスト再生のようになってしまいます。
    設定に原因があるのでしょうか?
    再生クライアントはビエラおよびディーガで確認しました。 -- (名無しさん) 2015-12-31 17:35:11
  • sMedio TV Suite クライアントで再生できませんか?
    http://www.smedio.co.jp/soft/products/dtcp-ip/smedio-tvsuite/

    デジタル放送の録画番組がありません。
    と表示されて番組が表示されません。 -- (us) 2015-12-31 16:49:46
  • 続きです

    [libvo_aacenc @ 02655f60] Unable to set encoding parameters
    Output #0, ipod, to 'hoge.mp4':
    Stream #0:0: Video: h264, yuv420p, 568x320 [SAR 160:213 DAR 4:3], q=-1--1, 90k tbn, 29.97 tbc
    Stream #0:1: Audio: aac, 48000 Hz, 5.1(side), s16, 128 kb/s
    Stream mapping:
    Stream #0:0 -> #0:0 (mpeg2video -> libx264)
    Stream #0:1 -> #0:1 (ac3 -> libvo_aacenc)
    Error while opening encoder for output stream #0:1 - maybe incorrect parameters such as bit_rate, rate, width or height
    -- (名無しさん) 2015-12-30 10:08:29
  • 続きです

    Stream #0:0[0x1e0]: Video: mpeg2video (Main), yuv420p, 720x480 [SAR 8:9 DAR 4:3], 9800 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc
    Stream #0:1[0x80]: Audio: ac3, 48000 Hz, 5.1(side), s16, 448 kb/s
    Stream #0:2[0x81]: Audio: ac3, 48000 Hz, stereo, s16, 192 kb/s
    [buffer @ 02657fc0] w:720 h:480 pixfmt:yuv420p tb:1/1000000 sar:8/9 sws_param:
    [yadif @ 02657320] mode:0 parity:-1 auto_enable:0
    [scale @ 02e80e80] w:720 h:480 fmt:yuv420p -> w:568 h:320 fmt:yuv420p flags:0x4
    [libx264 @ 02e80060] using SAR=160/213
    [libx264 @ 02e80060] frame MB size (36x20) > level limit (396)
    [libx264 @ 02e80060] MB rate (21578) > level limit (11880)
    [libx264 @ 02e80060] using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2
    [libx264 @ 02e80060] profile High, level 1.3
    [libx264 @ 02e80060] 264 - core 119 r2106 07efeb4 - H.264/MPEG-4 AVC codec - Copyleft 2003-2011 - http://www.videolan.org/x264.html - options: cabac=1 ref=3 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=6 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=0 weightp=0 keyint=250 keyint_min=25 scenecut=40 intra_refresh=0 rc_lookahead=40 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
    [libvo_aacenc @ 02655f60] Unable to set encod
  • forVIERA 1.74.2(Win7x86)で、iPodEncoderによるMP4変換ができません。
    0バイトのファイルだけが作られて即座に終了している感じです。
    ソースは、DVDisoからDVD VOB Extractで抽出したVOBファイルです。

    encode_m2ts V9.0で同じファイルにiPodEnc.batを適用したところ、
    以下のエラーが出ています。
    以前は出来ていたことなんですが、何が悪いのでしょう?

    ffmpeg version N-35051-g50d6f81, Copyright (c) 2000-2011 the FFmpeg developers
    built on Nov 21 2011 02:37:34 with gcc 4.6.2
    configuration: --enable-gpl --enable-version3 --enable-postproc --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libcdio --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-librtmp --enable-libspeex --enable-libvorbis --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libxvid --enable-libvpx --enable-libx264 --disable-ffserver --disable-ffplay --disable-ffprobe --enable-avisynth --enable-w32threads --extra-ldflags=-static --extra-cflags='-mtune=core2 -mfpmath=sse -msse' --optflags='-O2 -finline-functions'
    libavutil 51. 26. 0 / 51. 26. 0
    libavcodec 53. 36. 0 / 53. 36. 0
    libavformat 53. 21. 0 / 53. 21. 0
    libavdevice 53. 4. 0 / 53. 4. 0
    libavfilter 2. 49. 0 / 2. 49. 0
    libswscale 2. 1. 0 / 2. 1. 0
    libpostproc 51. 2. 0 / 51. 2. 0
    [mpeg @ 019385e0] max_analyze_duration 5000000 reached at 5005000
    Input #0, mpeg, from 'hoge.vob':
    Duration: 00:45:09.94, start: 0.233567, bitrate: 5952 kb/s
    Stream #0:0[0x1e0]: Video: mpeg2video (Main), yuv420p, 720x480 [S
  • 回答ありがとうございます。

    TranscodeExtensionsからmp4を削除

    RendererName=Panasonic

    上記にて実行しましたがだめでした。

    さらにMimeTypesChanges=audio/wav=audio/L16|video/mp4=video/mpeg|video/ts=video/mpeg

    MimeTypesChanges=audio/wav=audio/L16|video/ts=video/mpegに変更したところ、望み通りの結果となりました。

    ありがとうございました。 -- (tak) 2015-12-02 23:31:37
  • @takさん
    VIERA.confが選択されてると思いますがその中の
    RendererName=Panasonic VIERA
    からVIERAのキーワードを削除してみてください
    -- (Panasony) 2015-12-02 21:03:32
  • pmsからforVIERAに乗換えました。
    クライアントはTH-l42e60でpmsではどのバージョンでもmp4がトラスコ無しにてサクサク再生されていましたが
    forVIERAではうまくいきません。

    renderers/*.conf にて
    TranscodeExtensionsからmp4を削除

    上記も試しましたが改善されません。
    pmsと同じようには出来ないものでしょうか。 -- (tak) 2015-12-01 18:13:33
  • @asさん
    問題が解決するか判りませんが、バージョン1.74.3にて
    Mencoderのバージョン制御のアルゴリズムを変更しました。
    -- (Panasony) 2015-11-23 20:19:08
  • 回答ありがとうございます。返信遅くなりました。
    フォルダ名のxxxx部分には倍角は使っていません。

    mencoderを新し目のバージョンでビルドしたものをダウンロードしてきて
    差し替えても、同様のエラーが出たので、別の要因がありそうです。
    -- (as) 2015-11-21 09:44:12
  • @名無しさん
    youtubeの仕様変更に伴い、現在はプレイリストアドレスのPLが
    必要になったようです。
    Readmeを修正します。
    -- (Panasony) 2015-11-09 20:15:35
  • @asさん
    確認ですが
    C:\Users\xxxxx\AppData\Local\Temp\ps3mediaserver\
    のxxxxxに日本語等の倍角文字が使用されてませんか?
    そうであるなら最新版のmencoderが原因なので、回避ルーチンを 追加します。
    -- (Panasony) 2015-11-09 20:13:03
  • Readmeに記載されているyoutubeのプレイリスト再生について、(先頭のPLを除く)とあるのですが、PL有りでないと再生できませんでした。 -- (名無しさん) 2015-11-07 12:22:46
  • 切れてました。。

    INFO 2015-11-01 21:01:08.101 [StartPlaying Event] renderer: 192.168.11.5, file: D:\share\xxxxx.mp3
    DEBUG 2015-11-01 21:01:08.921 [Thread-22]
    DEBUG 2015-11-01 21:01:08.921 [Thread-21] ============ Sorry, this file format is not recognized/supported =============
    DEBUG 2015-11-01 21:01:08.921 [Thread-22] Exiting...
    DEBUG 2015-11-01 21:01:08.921 [Thread-21] === If this file is an AVI, ASF or MPEG stream, please contact the author! ===

    環境は
    Win10 64bit
    JAVA8 64bit
    PMS for Viera 1.74.2
    クライアント:DIGA DMR-BRT210
    設定はDIGA.confそのままです。 -- (as) 2015-11-01 22:51:12
  • いつも便利に使わせていただいています。

    この度Windows10の新環境へPMSを入れたのですが、
    mp3の再生ができません。
    mp4動画(tsMuxer)やyoutubeなどは見れています。

    DIGAなのでaudio_to_video = trueで動画偽装なのですが、
    mencoderでエラーになっています。
    何か確認すべき点があれば、教えてもらえませんか。

    [debug.log]
    DEBUG 2015-11-01 21:01:07.998 [mencoder.exe-1] Starting "C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe" -ss 0 "C:\Users\xxxxx\AppData\Local\Temp\ps3mediaserver\pms-avs-xxxxx.mp3.avs" -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=4 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=4:keyint=5:vqscale=1:vqmin=1:vrc_maxrate=54000:vrc_buf_size=1835 -slang off -ofps 30000/1001 -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1446379267717
    DEBUG 2015-11-01 21:01:08.014 [mencoder.exe-1] Reading pipe: \\.\pipe\mencoder1446379267717
    DEBUG 2015-11-01 21:01:08.014 [mencoder.exe-1] Attaching thread: mencoder.exe-1
    DEBUG 2015-11-01 21:01:08.054 [Thread-22] MEncoder PS43 (C) 2000-2015 MPlayer Team
    DEBUG 2015-11-01 21:01:08.054 [Thread-22] Custom build by Panasony (Invalid dvdcss hack)
    DEBUG 2015-11-01 21:01:08.055 [Thread-22]
    DEBUG 2015-11-01 21:01:08.062 [Thread-22] success: format: 0 data: 0x0 - 0x19f
    DEBUG 2015-11-01 21:01:08.064 [Thread-22] libavformat version 56.19.100 (internal)
    INFO 2015-11-01 21:01:08.101 [StartPlaying Event] renderer: 192
  • 返事遅くなりましてすみません。

    ご提案頂きました
    ・#-ビデオ設定-#フォルダ内のSeekByTimeの設定する
    ・PS3.confに VieraMod=true を追加する
    を実践しましたが、いずれもPS3上での再生時間表示は「00:00:00」のままでした。
    ちなみに
    ・PS3.conf上でSeekByTimeのtrue,falseそれぞれでの#-ビデオ設定-#フォルダ内のSeekByTimeのtrue,false
    の4パターンを試しましたが、ダメでした。
    さらに上の4パターンに
    ・PS3.confに VieraMod=true を追加する
    これもやってみましたがダメでした。

    ちなみにmencoder.exeの差し替えで音ずれは解決できませんでした。
    こっちの問題はいろいろ切りがなさそうなので、再生時間表示の問題がクリアになった後かなと思っております。

    そのほか試したほうがよいことあればアドバイスいただければと思います。

    宜しくお願い致します。 -- (ry) 2015-09-01 13:00:52
  • 返事がおそくなり申し訳ありません
    自分も時間がとれずにいたのですが、今ほど確認しましたところ、たしかに問題は解消されていました
    お騒がせしまして、重ね重ね申し訳ありませんでした -- (名無しさん) 2015-08-31 07:49:08
  • @名無しさん
    エスケープ文字の件ですが、short_title=2でも試しているのですが
    こちらでは再現できず原因が判りません
    -- (Panasony) 2015-08-25 00:05:26
  • >>\"のように エスケープ文字と思われる\が表示されます
    >の件は、short_title=2とした場合の「”」が変換されたもののようです

    この件、直して欲しい -- (名無しさん) 2015-08-24 16:47:46
  • @ryさん
    PS3の場合、PS3.conf上でSeekByTimeの設定を変更するのと
    #-ビデオ設定-#フォルダ内のSeekByTimeの設定するのとで
    動作が異なるようになってますので、#-ビデオ設定-#でも
    試して頂けませんか?
    また、PS3.confに VieraMod=true を追加すると動作が変わりますか?
    音ずれに関してはmencoderの問題の可能性がある為、古いバージョンの
    mencoderに差し替えると改善するかもしれません
    PS3 Media Server\win32フォルダ内のmencoder.exeを削除し
    mencoderPS37.exeをmencoder.exeの名前でコピーしてください
    -- (Panasony) 2015-08-19 22:46:18
  • 初めて投稿させていただきます。
    PS3でPCの動画を再生することが多いのですが、再生中PS3上での再生時間表示(動画の長さ表示)が「00:00:00」になります。
    おそらくタイムコードを取得できていないのがな、と思っていますが、これのせいかわかりませんが結構音声と映像がずれます。
    ノウハウのところに書かれてあった
    ■音ズレやカクつきが発生する場合
    バーチャルフォルダの #-ビデオ設定-# にて
    DVDISO Force 24fpsのtrue/falseや(デフォルト:true)
    ビデオと映像の同期を行なうのtrue/falseを切り替える(デフォルト:false)
    この辺はやってみましたが変わらずです。

    今のところ「00:00:00」になる条件として
    ・ファイルの拡張子は無関係ぽい(mkv、mp4で確認)
    ・トランスコードするとなる(MEncoder、AviSynth/MEncoder、tsMuxeRで確認)
    ・PS3のみでなる?(TVがBRAVIAのHX920なのですがこちらでは時間でました)
    こんなところです。
    三番目のPS3のみでなるのかと思いPS3.confのSeekByTimeオプションもいじってみましたが変わらずでした。

    それと正確には覚えていないのですが1.72.0から最新の1.74.2に上げた段階でこの問題が出てきた感じです(1.74.2にしてから音ずれが発生するようになったので)

    何かアドバイスがあれば教えていただきたいです。

    最後に当方の環境を書いておきます。
    Windous7 64bit
    JAVA8 64bit update51
    PMS for VIERA 1.72.0(最新の1.74.2でも試しましたが変わらずです)

    宜しくお願いします。 -- (ry) 2015-08-19 00:39:54
  • 動作、確認しました。ありがとうございました。

    ついでと言っては何ですが、ひとつ要望があります。
    pmsvfで、DVDiso等のファイルをフルパスで記述しますが
    後々パス名の変更があったとき修正が大変です。
    (フルパスで記述する意義は理解してますが)

    そこでDOSのバッチファイルのように、環境変数的なものを使えるようにできないでしょうか?
    pms.conf等でDVDISOPATH=F:\DVDISOなどとしておけば、
    pmsvf側で、%DVDISOPATH%のように参照できる。
    パスが変わったときは、環境変数の定義1箇所を変えればよい、というような。

    ご検討いただけませんでしょうか。よろしくお願いします。 -- (名無しさん) 2015-07-02 21:39:35
  • @名無しさん
    先頭に-dvd-deviceが来ると誤動作するようになってました
    バージョン1.74.2で修正しました
    -- (Panasony) 2015-07-02 20:41:00
  • 変化ありませんでした
    mencoder自体は正常に起動されており、
    最終的にやはり文字化けによると思われるcan't openで終わっています
    (エラー内容は先に挙げたものと全く同じ)
    -- (名無しさん) 2015-07-02 07:37:24
  • @名無しさん
    = と -dvd-device の間にスペースを入れてください
    -- (Panasony) 2015-07-01 21:37:13
  • ↓こんな感じです。
    ファイル名:DVD_2-1_T3 エピソードタイトル.pmsvf
    --------------------------------
    title=(エピソードタイトル)
    mencoder=-dvd-device "F:\DVD\ほげ\01 はげ\2 ABC\ISO版\DVD_2-1.iso" dvd://3 -msglevel statusline=2 -oac copy -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=1 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=4:keyint=5:vqscale=1:vqmin=1:vrc_maxrate=54000:vrc_buf_size=1835 -font C:WINDOWSFontsArial.ttf -subfont-text-scale 3 -subfont-outline 1 -subfont-blur 1 -subpos 98 -fontconfig -aid 129 -sid 0
    chapter=00:00:00.000
    chapter=00:06:09.600
    chapter=00:13:01.133
    chapter=00:15:11.266
    chapter=00:22:41.366
    chapter=00:29:35.333
    chapter=00:34:22.200
    chapter=00:41:11.934
    chapter=00:45:28.267
    -- (名無しさん) 2015-07-01 20:48:11
  • @名無しさん
    pmsvfをどの様に書いてるか詳しく教えてください
    -- (Panasony) 2015-07-01 20:15:55
  • >\"のように エスケープ文字と思われる\が表示されます
    の件は、short_title=2とした場合の「”」が変換されたもののようです -- (名無しさん) 2015-07-01 01:04:18
  • 1.74.1を試してみましたが、pmsvfの再生不具合は依然発生します
    エラーの内容も同じです。なぜでしょうか?

    また、自分でつけたタイトルに"(半角ダブルクォート)がある場合、\"のように
    エスケープ文字と思われる\が表示されます

    ご報告まで -- (名無しさん) 2015-07-01 00:47:31
  • @名無しさん
    pmsvfによるDVDISOファイルの再生不具合の件は
    バージョン1.74.1で修正しました。
    recently_dir_nameの件ですが全角文字も使用可能ですが
    Unicodeエスケープシーケンス形式で 記述する必要があります。
    http://yasu0120.blog130.fc2.com/blog-entry-17.html
    のサイトで変換できます
    例えば
    最近再生したファイル

    \u6700\u8FD1\u518D\u751F\u3057\u305F\u30D5\u30A1\u30A4\u30EB
    となります。 -- (Panasony) 2015-06-29 23:01:52
  • いつもお世話になります。
    1.74を試していますが、pmsvfの再生ができません。
    debug.logによると、pmsvf内でDVDisoファイルを読み込むときに全角ファイル名(当方では全角フォルダ名)が文字化けし、can't open となっているようです。

    --------------------------------------------------------
    MEncoder PS43 (C) 2000-2015 MPlayer Team
    Custom build by Panasony (Invalid dvdcss hack)


    Exiting...
    libdvdread: Could not open F:\ほげ\ほげ\dvdiso.iso with libdvdcss.
    libdvdread: Can't open F:\ほげ\ほげ\dvdiso.iso for reading
    Couldn't open DVD device: F:(文字化け)\(文字化け)\dvdiso.iso (No such file or directory)
    No stream found to handle url dvd://1
    Cannot open file/device.
    Process C:\Users\Owner\Documents\PS3 Media Server\win32\mencoder.exe has a return code of 1! Maybe an error occurred... check the log file
    --------------------------------------------------------

    同梱のmencoderPS37を使うと問題ありません。
    また、そのDVDisoファイルを直接視聴することは問題ありません。

    それから別件ですが、recently_dir_nameに全角文字を使うと文字化けするようですが、半角文字のみの仕様でしょうか?

    対処願えますと幸いです。よろしくお願いします。 -- (名無しさん) 2015-06-28 23:16:16
  • @pokyさん
    クライアントの*.conf内のTranscodeVideoの設定が
    クライアントの仕様に合っていないのかもしれません
    -- (Panasony) 2014-11-18 00:19:22
  • いろいろ教えて頂きありがとうございます。
    ようやく動画の再生が出来ました!が・・音声が出ない><;
    いろいろ調べてみたんですが全く分からず・・・
    ここを弄ったらいいような所は有るでしょうか? -- (poky) 2014-11-17 13:09:56
  • @pokyさん
    いいえ、そのメッセージはアクセスを許可したという事なので
    正常動作してるという事です
    -- (Panasony) 2014-11-16 20:48:37
  • Panasonyさん有難うございます。
    無事エラー葉で無くなりましたが、今度は

    no ip filter specifind,access granted to / 192.168.**.** とでます。

    これが原因でTVで見れないのでしょうか? -- (poky) 2014-11-16 09:18:02
  • @pokyさん
    下記エラーですがサンプルとしてWEB.confに記述している
    videofeed.Web,SAMPLE=http://gdata.youtube.com/feeds/api/playlists/90693D98FCF26180
    のyoutube参照先がユーザーによって削除された事が原因のようです。
    WEB.confの該当行を削除すればエラーは消えると思います。
    -- (Panasony) 2014-11-15 16:14:00
  • 教えて頂けないでしょうか・・
    PMS VIERAをインストールして起動したところ
    下記のエラーがたくさん出てきます。
    解決法分かりますでしょうか?


    ERROR 2014-11-15 12:54:09.281 [pool-38-thread-1] Error in parsing stream: http://gdata.youtube.com/feeds/api/playlists/90693D98FCF26180
    java.io.IOException: Server returned HTTP response code: 403 for URL: http://gdata.youtube.com/feeds/api/playlists/90693D98FCF26180
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source) ~[na:1.8.0_25]
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) ~[na:1.8.0_25]
    at net.pms.network.HTTPResource.downloadAndSendBinary(HTTPResource.java:169) ~[pms.jar:na]
    at net.pms.network.HTTPResource.downloadAndSendBinary(HTTPResource.java:145) ~[pms.jar:na]
    at net.pms.dlna.Feed.parse(Feed.java:110) ~[pms.jar:na]
    at net.pms.dlna.Feed.resolve(Feed.java:95) ~[pms.jar:na]
    at net.pms.dlna.DLNAResource.run(DLNAResource.java:872) [pms.jar:na]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [na:1.8.0_25]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.8.0_25]
    at java.lang.Thread.run(Unknown Source) [na:1.8.0_25]
    -- (poky) 2014-11-15 13:05:26
  • お世話になります。
    その後、改めて他の方の書き込みを参考に
    アンインストールし、再起動後にインストールし直したところ、
    本戸お降りになりました。
    結局、何が問題だったのかよく分かりませんが、
    お騒がせいたしました。ありがとうございました。 -- (Ryoukou) 2014-11-10 07:31:07
  • @Ryoukouさん
    確認ですが、ファイル名やフォルダー名を変更すれば
    問題なく再生できるという事ですか?
    再生できないトラブルの原因としてファイヤーウォールにより
    弾かれてしまうというのが良くあります。
    ファイヤーウォールの除外設定にPMSとjavaw.exeが入ってる事を
    確認してください。
    またログに何かメッセージが出力されていないか確認してください。
    (ログのレベルをALL等に上げた方が良い)
    -- (Panasony) 2014-11-08 00:29:13
  • やってみました。旧バージョンをインストールし直しても、
    状況は変わりませんでした。
    何が原因なのでしょう。
    そういえば、javaもアップデートしましたが、
    それが原因なのでしようか。
    なにぶん、専門的な知識に乏しいので、
    よろしくお願いいたします。 -- (Ryoukou) 2014-11-07 20:21:44
  • @Ryoukouさん
    バージョンアップが原因か明確にする為、旧バージョンを再度
    インストールし直して頂けませんか? -- (Panasony) 2014-11-06 23:54:39
  • 初めて投稿させていただきます。
    windows7 64bitPCで使用しています。
    1.71.0バージョンをインストールして、何ら問題なく視聴していましたが、
    1.72.0にバージョンアップしたとたん、日本語フォルダ内のtsファイル、
    また日本語ファイ名のisoファイルが再生できなくなりました。
    どのように対処すれば良いか、ご教授願えないでしょうか。 -- (Ryoukou) 2014-11-06 11:45:09
  • @名無しさん
    DIGAで早送りや早戻しはできると思います。
    ダウンロードも問題無く出来るようです。
    -- (Panasony) 2014-10-31 21:41:53
  • このソフトをWindows PCにインストールして、ブルーレイレコーダーDIGAでPCのTS動画を再生するとき、早送りや早戻しはできるのでしょうか?
    Windows OSのDLNA機能では再生させると早送り、早戻しができませんでした。

    あと、プログラムのダウンロードができません。 -- (名無しさん) 2014-10-30 19:57:44
  • 以前、m2tsの頭だしについて質問していた者です。
    遅ればせながら1.72.0のlink_offsetを試しました。
    バッチリでした。ありがとうございました。 -- (名無しさん) 2014-09-16 09:10:51
  • @名無しさん
    インストールの際、インストールパスが表示されてると思いますが
    そのパスを変更してみてください
    インストール後、そのパスにpms.exeが存在する事を確認してください
    また、起動アイコンのプロパティにてリンク先や作業フォルダのパスが
    正しいかどうか確認してください。
    -- (Panasony) 2014-06-02 19:40:58
  • 完全にアンインストールし、PCを再起動して再インストールしてみました。

    同じ結果でした。

    どうしたら良いでしょう。


    実は、PMS for VIERAを再インストールする前に
    ps3 media server1.90.1(for VIERA)をインストールしてしまいました。
    起動させたところ、アイコンが違ったのですが、このまま見れればいいやと思い、
    テレビを見たところ音声しか出ないので、VIERA用のが会ったと思いだし、アンインストールし、
    PMS for VIERA 1.71.0 Windowsをインストールしました。

    このことと何か関係あるでしょうか? -- (名無しさん) 2014-06-01 11:58:51
  • @名無しさん
    もう一度完全にアンインストールしてください。
    もしアイコンやスタートメニューが残っていたら手で消してください。
    アンインストール後はPCを再起動して再インストールしてみてください。
    -- (Panasony) 2014-05-31 23:09:56
  • 困っています。

    PMS for VIERAを使用しておりましたが、引っ越しをし、起動させたところ、PMS for VIERAが使用できない状態になっておりました。

    そこで、PMS for VIERAとAvysyinthをアンインストールし、最新版のPMS for VIERA 1.71.0 Windowsをインストールしたところ、
    アイコンの矢印マークが出ず、違うアイコンです。

    クリックすると、ショートカットの検索画面が出てきて、
    「pms.exeを探しています。自分で探す場合は、[参照]をクリックして下さい。」
    というメッセージが出ます。

    探しても、pms.exeは見つかりません。

    どうしたら、正しく起動できますか? -- (名無しさん) 2014-05-31 13:25:35
  • MAC OS X 10.9.2 + VIERA VT3 にて作動しております。
    非常にキビキビ動作しており、少々感動しておるところです。
    そこで、少々レポートさせていただきます。

    環境は前述の通りですが、PMS本体は下記の通りMac版と合成しました。

    1. 最新版のMac用PMS(1.90.1)をダウンロードしてインストール。
    2. 貴ホームページより最新版PMS for VIERA(1.71.0)をダウンロードして解凍(特にexe実行環境が無ければダブルクリックで解凍できますよ) 。
    3. 上記2.で解凍したフォルダから下記4点(2フォルダ、2ファイル)をコピーして、/Applications/PS3 Media Server.app/Contents/Resources/Java にペーストし置き換え。
    (フォルダ)plugins、renderers (フォルダ)PMS.conf、pms.jar
    *ペースト先はここでいいのか、置き換えてしまっていいのかは不明でしたが。。。
    4. 起動すると、特にエラーも無く動作します。
    5. 設定
    字幕言語の優先: jpn,eng,fre,ger,und
    Forced sub: ja
    字幕の文字コード: cp932 /* Japanese */
    True Type フォント: /Library/Fonts/Osaka.ttf
    字幕フォルダのパス PMS 
    等、下記URLを参考にして設定しました。
    http://www.katch.ne.jp/~kakonacl/douga/ps3/setei.html

    動作状態
    1. ビエラ本体のお部屋ジャンプリンクは、サーバー一覧にPMSが表示されるのですが、選択しても中身はブランク。
    3〜4時間待っても変わらないので、DMCアプリ(iPHONE)を使用。
    2. DIXIM DMCを使用して、メディアサーバーからPMSを選択。#--MEDIAライブラリ--# -> ビデオ -> すべてのビデオ -> #--TRANCECODE--# -> ビデオを選択。
    3. 上記2.のパス以外ではうまく再生できません。
    4. 字幕の表示は、SRTなどの外部ファイルになっているものは表示されますが、MKVファイル等で内部に包含されている場合はうまく表示されません。
    *これら2.〜3.の問題は、設定が間違えていたのか、前述のPMSファイルの置換えに問題があるのか、もし何かわかりましたらコメントいただけると幸いです。

    TV本体のお部屋ジャンプリンク画面からしようできないことや字幕の件は少々問題ですが、基本的に快適に使えております。

    何かの参考まで。
    -- (名無しさん) 2014-04-06 22:24:21
  • ありがとうございます。DLできました。 -- (名無しさん) 2014-04-06 00:18:40
  • @名無しさん
    現在は特に問題ないようです。
    -- (Panasony) 2014-04-04 21:26:13
  • どうもダウンロードができないようなのですが、いかがでしょうか? -- (名無しさん) 2014-04-04 01:15:56
  • @名無しさん
    NoEncodeはトランスコードを行わずにダイレクトにストリームを送信するので
    ログに出力されません。tsやm2tsはトランスコードする必要が無い為、通常は
    NoEncodeで再生します。(pmsvf等を使用しない通常のm2ts再生はNoEncodeです)
    高解像度のファイルをmencoder=でスムーズに再生させるにはサーバーマシンの
    スペックを上げるか、リサイズ設定で表示サイズを小さくするしか方法がありません。
    -- (Panasony) 2014-03-22 11:15:08
  • チャプター機能というのは、トラスコフォルダ内の、という意味でしょうか?
    できれば、個々の番組を独立させたいので、pmsvfかvbsにしたいのです
    関係ないかもしれませんが、トラスコフォルダ内のチャプターを使用した場合、
    再生カクカク現象が起きます。NoEncodeのチャプターでは起きません。
    そのため、カクカクしなかった(と思われる)ログをpmsvfのmencoder=に
    貼り付けてみたのですが、結果はカクカクです。
    何か原因として考えられることはありますか?

    ちなみに、NoEncodeと通常のものとの差異はどこにあるのでしょうか
    再生結果が違うのは明白なのに、ログを見ると何が違うのかわからないのです・・・ -- (名無しさん) 2014-03-22 08:52:40
  • @名無しさん
    mencoder=はトランスコードになりますから負荷が掛かりますが
    avisynthもmencoderによるトラスコですから更に負荷が掛かるはずです。
    チャプター機能であればダイレクト再生が可能なのでVIERA側で副音声を選択でき
    良いと思いました。
    mencoder=はダイレクトにコマンドが実行されるので-opfsオプションも効きます
    -- (Panasony) 2014-03-18 19:32:34
  • すみません。正確には、チャプターではなく、pmsvfのmencoder=ほげ.m2ts -ss xxx です。
    (個々の番組を指定する個別のファイルをつくりたかったので)
    カクカクになることと関係ありますか?

    それと別件ですが、pmsvfでmencoder=に-opfsオプションを指定した場合、再生時に適用されますか? -- (名無しさん) 2014-03-18 12:42:55
  • >avisynthを使用するよりチャプター機能を使った方が良いと思います

    当初はチャプターを試したのですが、異様に負荷が高く、再生もカクカクになってしまいました
    それでavisynthにしました(高負荷ではありますが、再生自体は問題ないようです)。 -- (名無しさん) 2014-03-18 12:36:28
  • @名無しさん
    avisynthを使用するよりチャプター機能を使った方が良いと思います
    対象ファイルの*.confを作成して、その中でタイトルやチャプター定義
    をしてください。
    -- (Panasony) 2014-03-16 20:54:59
  • 複数番組が連続しているm2tsファイル(H264+AAC)があるのですが、
    個々の番組の頭出しをしようと、以下のavisynthスクリプトを作りました。

    SOURCE = DirectShowSource("ほげ.m2ts")
    clip = trim(SOURCE, 14500, SOURCE.FrameCount)
    return clip

    番組の再生自体はうまくいったのですが、元の音声が二ヶ国語で、
    avisynth再生をすると、2ヶ国語が混ざって聞こえます。
    再生機であるビエラ側では、元のファイルの再生では音声を選べますが、
    avisynth再生では選べなくなっています。

    主音声(日本語)をだけを再生する方法はありますか?
    -- (名無しさん) 2014-03-16 14:25:11
  • 自己解決しました。
    1.71.0に更新したら、再生できるようになりました。
    お騒がせ致しました。 -- (名無しさん) 2014-03-16 10:36:34
  • お世話になっております。
    youtubeが見られなくなっていないでしょうか。
    最新版での確認をお願い致します。
    もし、最新版では可能なのであれば、私のほうを更新しようかと思います(現在、1.67.1を使用中)。
    よろしくお願い致します。 -- (名無しさん) 2014-03-15 22:11:32
  • Recently Filesフォルダのフォルダ名を変えられるようにしてほしいです -- (名無しさん) 2014-02-26 10:25:22
  • >pmsvfのリンク機能は全てリンク先の設定に依存します。
    すみません。古いバージョンを使っていて勘違いしていました。
    最新を使うことでおっしゃるようになりました。
    サムネ対応の方、できたらお願いします。 -- (名無しさん) 2014-02-22 22:48:13
  • @名無しさん
    pmsvfのリンク機能は全てリンク先の設定に依存します。
    つまりリンク先のDVDISOの置かれたディレクトリにそのDVDISO用の
    *.confファイルを作成し、その中でタイトルやチャプター定義をしてください
    -- (Panasony) 2014-02-22 19:12:03
  • ついでと言っては何ですが要望をひとつ。pmsvfでサムネイル表示に対応してほしいです
    動画から動的に取り出せるのが理想ですが(isoのチャプター再生のようにコマンドベタ打ちでも)、
    無理ならサムネ用の静止画を指定する形だけでもあるとうれしい -- (名無しさん) 2014-02-22 15:42:44

最終更新:2011年07月18日 01:40