アットウィキロゴ

AAA


Authentication(認証)、Authorization(認可)、Accounting(アカウンティング、利用の記録)の頭文字をとった呼び方です。主に、ネットワークへの接続を、利用者ごとに認証し、許す範囲を決め、利用を記録する仕組みを指します。

標準の中での使われ方

RFC 6733 は、Diameter の基本のプロトコルを、ネットワークへの接続や IP モビリティ(構内でもローミング中でも)のようなアプリケーションのための「認証・認可・アカウンティング(AAA)の枠組み」を提供するもの、としています。

3つの A

A 役割
Authentication(認証) 接続してきたのが誰かを確かめる
Authorization(認可) その利用者に、何を許すかを決める(接続してよいか、どのネットワークにつなぐか)
Accounting(アカウンティング) いつ、誰が、どれだけ使ったかを記録する。課金、容量の管理、事後の調査に使う
3つ目の Accounting は、責任追跡性(accountability。操作を主体にたどれる性質)とは別の言葉です。Accounting で残す記録は、責任追跡性を支える材料の一つです。

代表的なプロトコル

プロトコル 内容
RADIUS ネットワークへの接続の装置(Wi-Fi のアクセスポイントや VPN の装置など)と、共有の認証サーバの間で、認証・認可・設定(割り当てる IP アドレスなど)の情報を運ぶ(RFC 2865、2000年6月)。利用の記録は別の仕様(RFC 2866)で運ぶ
Diameter ネットワークへの接続や、移動しながらの接続・ローミングのための AAA の枠組み(RFC 6733、2012年10月)
社内の Wi-Fi や VPN で、利用者ごとに認証し、つなぐ先を変える仕組みは、AAA のサーバと組み合わせて作ることが多いです(VPN)。

アクセス制御の流れとの関係

AAA の前提には、利用者を一意に識別できることがあります。識別・認証・認可・責任追跡性の流れは、アクセス制御の基本の考え方です。

関連するページ

流れ:識別 → 認証 → 認可 → 責任追跡性(全体はアクセス制御)
Diameter・VPN

出典

確認日:2026年10月16日
最終更新:2026年10月16日 17:53